Python安装matplotlib库失败解决方法【Command errored out with exit status 1】

Python安装matplotlib库失败解决方法【Command errored out with exit status 1】
强烈推介IDEA2020.2破解激活,IntelliJ IDEA 注册码,2020.2 IDEA 激活码

很多刚开始学习python的童鞋都会安装第三方库,例如matplotlib,numpy,pandas,jupyter等等。但是通过终端命令pip安装的时候总会遇到各种各样的问题,导致安装不成功。从安装到放弃~~~~ 例如以下问题:
在这里插入图片描述
在这里插入图片描述

Python 安装matplotlib失败解决方法:(命令提示符安装)

首先可以更新升级pip,管理员方式进入CMD窗口下,执行python -m pip install -U pip setuptools,将pip升级到最新版本。

然后观察安装失败提示,大概的意思是电脑安装的python版本和要安装的matplotlib版本有冲突,不支持该版本安装。错误提示信息类似 Command errored out with exit status 1:这种。
在这里插入图片描述
既然知道原因了,那下面就可以对症下药解决啦~~~

  1. 看下安装python安装版本是多少。例如博主就是3.8.0版本的。(可以通过python --version指令查看)

  2. 去https://www.lfd.uci.edu/~gohlke/pythonlibs/找到matplotlib对应版本的whl文件。
    在这里插入图片描述
    博主下载就应该是找matplotlib‑3.2.2‑cp38‑cp38‑win_amd64.whl这一个,其中cp38代表3.8版本,win_amd64代表Windows系统64位。

  3. 下载对应的whl文件后,在cmd下进入刚刚下载的whl所在的文件夹。最后再输入pip install matplotlib‑3.2.2‑cp38‑cp38‑win_amd64.whl进行安装就可以了。

  4. 安装完成后,可以在cmd通过 python -m pip list 指令查看已安装的库列表和对应版本。

在这里插入图片描述
总结:
通过以上方法一般就可以解决类似matplotlib,numpy,pandas等第三方库,安装过程中出现的Command errored out with exit status 1:版本冲突问题啦!

创作不易,白嫖不好,各位的支持和认可,就是我创作的最大动力,我们下篇文章见!

Dragon少年 | 文 【原创】

如果本篇博客有任何错误,请批评指教,不胜感激 !
在这里插入图片描述

本文来源Dragon少年,由架构君转载发布,观点不代表Java架构师必看的立场,转载请标明来源出处:https://javajgs.com/archives/13860

发表评论