vmd安装包_VMD 1.9.1 安装和使用(Centos6.3)[通俗易懂]

vmd安装包_VMD 1.9.1 安装和使用(Centos6.3)[通俗易懂]今天使用了VMD1.9.1,过程如下:1.下载安装包下载地址是http://www.ks.uiuc.edu/Research/vmd/,选择适合自己系统的安装包。我的系统是Centos6.3,所以下载的安装包是:vmd-1.9.1.bin.LINUXAMD64.opengl.tar.gz2.解压缩包tar-zxvfvmd-1.9.1.bin.LINUXAMD64.opengl.tar...

今天使用了 VMD 1.9.1,过程如下:

1. 下载安装包

下载地址是http://www.ks.uiuc.edu/Research/vmd/,选择适合自己系统的安装包。

我的系统是Centos 6.3,所以下载的安装包是:vmd-1.9.1.bin.LINUXAMD64.opengl.tar.gz

2. 解压缩包

tar -zxvf vmd-1.9.1.bin.LINUXAMD64.opengl.tar.gz ,当前目录下会生成vmd-1.9.1文件夹

3. 进入目录配置

cd vmd-1.9.1

./configure LINUXAMD64

(系统没有提示)

./configure

系统提示:using configure.options:LINUXAMD64

注:如果不执行./configure LINUXAMD64,直接执行./configure系统会报错:

LINUX OPENGL FLTK TK ACTC IMD SPACEBALL LIBTACHYON VRPN NETCDF TCL PYTHON PTHREADS NUMPY SILENT

4. 编译

cd src

make install

5. 修改环境变量

VMD默认安装在/usr/local/bin下,所以修改~/.bashrc文件,把/usr/local/bin加入到PATH中,并且source ~/.bashrc确保修改生效

6. 如果需要,安装freeglut库

VMD的运行需要OPENGL库,运行VMD前要确保相关库已经正确安装。我一般习惯用freeglut,所以我的安装命令是:

yum install freeglut*

7. 运行VMD

在终端中键入vmd即可。

今天最困惑的问题是在第一台机器上安装后,运行vmd时出core,由于该机器正在运行测试程序,不便排查。换了第二台机器同样的步骤安装,运行成功!

两台机器的系统都是Centos6.3。

希望很快可以查到原因。

本文来源hust2014wt,由架构君转载发布,观点不代表Java架构师必看的立场,转载请标明来源出处:https://javajgs.com/archives/166093
0
 

发表评论