华为vlan配置实例详解_华为允许vlan通过

华为vlan配置实例详解_华为允许vlan通过 按照实验拓扑图接线。配置PC1:IP(192.168.1.1/24),PC2:IP(192.168.2.1/24)。 测试PC1和PC2的连通性:用PC1去PingPC2,查看Ping的结果,并解释原因。 PC1和PC2在不同的网段,不能ping通 配置PC1:IP(192.168.1.1/24),PC2:IP(192.168.1.2/24),PC3:IP(192...

 

  • 按照实验拓扑图接线。

华为vlan配置实例详解_华为允许vlan通过

  • 配置PC1:IP(192.168.1.1/24),PC2:IP(192.168.2.1/24)。
  • 测试PC1和PC2的连通性:用PC1去PingPC2,查看Ping的结果,并解释原因。

华为vlan配置实例详解_华为允许vlan通过

 

PC1和PC2在不同的网段,不能ping通

 

  • 配置PC1:IP(192.168.1.1/24),PC2:IP(192.168.1.2/24) ,PC3:IP(192.168.1.3/24) ,

PC4:IP(192.168.1.4/24) ,PC5:IP(192.168.1.5/24)。

  • 测试各PC之间的连通性,查看Ping的结果,并解释原因。

 

 

PC1 ping PC2

华为vlan配置实例详解_华为允许vlan通过

PC1 ping PC3

华为vlan配置实例详解_华为允许vlan通过

PC1 ping PC4

华为vlan配置实例详解_华为允许vlan通过

PC1 ping PC5

华为vlan配置实例详解_华为允许vlan通过

 

PC1 能够ping 通PC2-PC5 说明网络连通

因为PC1-PC5在同一个网关

 

 

 

  • 配置VLAN

(1)LSW1交换机配置

<Huawei>system-view         //进入系统视图

[Huawei]sysname sw1         //给交换机命名

[sw1]vlan 10                  //创建VLAN10

[sw1-vlan10]vlan 20         //创建VLAN20

[sw1-vlan20]display vlan    //显示VLAN信息

华为vlan配置实例详解_华为允许vlan通过

[sw1-vlan20]quit         //退回上一级视图

[sw1]interface Ethernet 0/0/1          //进入以太网接口0/0/1

[sw1-Ethernet0/0/1]port link-type access         //配置接口类型为Access

[sw1-Ethernet0/0/1]port default vlan 10          //分配接口给VLAN1

[sw1-Ethernet0/0/1]quit

[sw1]interface Ethernet 0/0/2

[sw1-Ethernet0/0/2]port link-type access

[sw1-Ethernet0/0/2]port default vlan 10

[sw1-Ethernet0/0/2]quit

[sw1]interface Ethernet 0/0/3

[sw1-Ethernet0/0/3]port link-type access

[sw1-Ethernet0/0/3]port default vlan 20

[sw1-Ethernet0/0/3]display vlan

华为vlan配置实例详解_华为允许vlan通过

(2)LSW2交换机配置

<Huawei>system-view

[Huawei]sysname sw2

[sw2]vlan batch 10 20           //批量创建VLAN

[sw2]display vlan

华为vlan配置实例详解_华为允许vlan通过

[sw2]interface Ethernet 0/0/1          //进入以太网接口0/0/1

[sw2-Ethernet0/0/1]port link-type access         //配置接口类型为Access

[sw2-Ethernet0/0/1]port default vlan 10          //分配接口给VLAN1

[sw2-Ethernet0/0/1]quit

[sw2]interface Ethernet 0/0/2

[sw2-Ethernet0/0/2]port link-type access

[sw2-Ethernet0/0/2]port default vlan 20

[sw2-Ethernet0/0/2]display vlan

华为vlan配置实例详解_华为允许vlan通过

  • 验证VLAN配置
  1. 测试PC1和PC2的连通性,并解释原因。
    1. 华为vlan配置实例详解_华为允许vlan通过
    2. 因为在同一个vlan且在相同的网段,所以PC1和PC2能够ping通
  2. 测试PC1和PC3的连通性,并解释原因。
    1. 华为vlan配置实例详解_华为允许vlan通过
    2. 因为PC1和PC3不在同一个vlan中,所以PC1和PC3不能ping通
  3. 测试PC1和PC4的连通性,并解释原因。
    1. 华为vlan配置实例详解_华为允许vlan通过
    2. 虽然PC1和PC4在同一个vlan且在同一个网段中,但是sw1和sw2交换机没有配置tunk端口,access端口没有tag标记,通不过tunk端口,所以ping不通!
  • 配置trunk接口
  1. LSW1的配置

[sw1]interface Ethernet 0/0/4

[sw1-Ethernet0/0/4]port link-type trunk       //配置接口类型为trunk

[sw1-Ethernet0/0/4]port trunk allow-pass vlan 10 20//trunk口允许通过的VLAN

  1. LSW2的配置

[sw2]interface Ethernet 0/0/3

[sw2-Ethernet0/0/3]port link-type trunk

[sw2-Ethernet0/0/3]port trunk allow-pass vlan 10 20

  • 验证trunk接口配置:测试PC1和PC3的连通性,并解释原因。

华为vlan配置实例详解_华为允许vlan通过

PC1和PC4能够ping通,因为交换机之间设置了trunk接口,使得不同vlan之间能够通过其他的交换机!

 

思考:

  1. 什么情况下,我们才会去划分VLAN。

让网络进行逻辑隔绝,才会划分vlan!不同的vlan中,即使在相同的网段也不能ping通,

  1. 什么情况下,我们才会去配置trunk接口。
    1. 要让交换机和交换机之间连通,需要设置trunk接口
本文来源末磨,由架构君转载发布,观点不代表Java架构师必看的立场,转载请标明来源出处:https://javajgs.com/archives/209801
0

发表评论